Installer openHAB sur Debian

Configuration initiale

Si lorsque tu vérifies le status du service, il te dit que tout va bien comme ceci :

cedcox@openhab-demo:~$ sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
   Loaded: loaded (/lib/systemd/system/openhab2.service; disabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-09-23 19:49:42 CEST; 8s ago
     Docs: https://www.openhab.org/docs/
           https://community.openhab.org
 Main PID: 3866 (java)
    Tasks: 95 (limit: 2358)
   Memory: 516.2M
   CGroup: /system.slice/openhab2.service
           └─3866 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/openhab2/runtime -Dopenhab.u

sept. 23 19:49:42 openhab-demo systemd[1]: Started openHAB 2 - empowering the smart home.
cedcox@openhab-demo:~$ 

Alors tu peux lancer ton navigateur et arriver sur la page de configuration initiale. Perso, pour les articles de ce blog, j’ai appelé mon serveur openhab « openhab-demo ». Ce qui donne l’URL suivante :

https://openhab-demo:8443/start/index

On oublie pas le httpS ainsi que :8443 qui est le port d’écoute du service openhab2.

Normalement, tu devrais arriver là-dessus

Configuration initiale
Configuration initiale

Cliquons sur « Standard »

Là, il se peut qu’il te demande de te localiser. Ce n’est pas pour envoyer les chinois du FBI mais simplement pour utiliser cette information dans différents plugins comme la météo par exemple.

install en cours
install en cours

Et une fois sur la page ci-dessous, l’installation et la configuration initale sont terminées.

Installation terminée
Installation terminée

5 Comments

  1. Salut Ced question sur lequel je cherche depuis deux jour, je sais que tu utilise des machine virtuel pour des test au vu des tutos! j’ai un problème avec celle sous openhab avec VMWare cela fait 2 jours que je cherche sur tout les forum et que je refait l’installation mais rien a faire je suis bloquer!
    une fois l’installation fini en me connectant a la page web de openhab j’ai ca.

    HTTP ERROR 404

    Problem accessing /start/index. Reason:

    Not Found

    aurez-tu déjà eu le cas?

    • Est ce que tu as bien démarré le service ?
      sudo systemctl start openhab2

      Si il ne démarre pas, il faut aller voir dans les logs

      Ced

  2. Toi aussi il de faut une deuxième vie pour faire tous se que tu aimerais! plus qu’a trouver une solution pour être insomniaque sans conséquence physique ou morale

  3. Oyé Oyé Merci à toi et oui le dilemnne du plaisir et du boulot et souvent rappeler à l’ordre par la fin du mois! en tous cas un plaisir de te lire à nouveau sur le sujet d’openhab qui manque cruellement en français. Surtout n’arrête pas c’est vraiment un plaisir et une aide

    • Effectivement, le temps manque ! Si les journées pouvaient faire 36 heures, ce serait plus simple 😀
      Mais je vais essayer de continuer 😉

      A bientôt JC

Poster un Commentaire

Votre adresse de messagerie ne sera pas publiée.


*


Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.